Job processing delays
Incident Report for FreeAgent
Resolved
Normal service has been resumed. If you experience further issues please contact support@freeagent.com.
Posted 5 months ago. Nov 27, 2017 - 10:08 GMT
Investigating
We are experiencing delays with job processing which is affecting emails, statement uploads and some recalculations. We are working to correct the issue.
Posted 5 months ago. Nov 27, 2017 - 08:08 GMT